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Quick Start Guide
Introduction

RAK3244 BastWAN puts the RAK4260 module into a Feather compatible format, developed by ElectronicCats
The RAK4260 LPWAN Module that is used as the core of RAK3244 BastWAN is based on Microchip’s SAM R34
(R34J18B). It is a SiP device integrating a 32-bit ARM Cortex -M0O+ MCU with a LoRa Transceiver. It offers full
coding support with the Arduino™ IDE.

For more information about the board, check the ElectronicCats RAK3244 BastWAN repository

Hardware Setup

The BastWAN is a Feather breakout board with everything you need to get started on your project.

WARNING

Before powering the Feather Board, make sure that you have already connected the included LoRa
Antenna. Not doing so might damage the board.

Software Setup
Burning a Bootloader

RAK3244 BastWAN board comes with pre-flashed bootloader upon purchase. However, if it is necessary to
replace the bootloader, you can burn the bootloader-bast-wan-v3.4.0.bin [ with Jlink as demonstrated below:
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Figure 1: Burning the bootloader

You can also flash the bootloader by using the RAKDAP1 Flash and Debug Tool[% . The guide on how to connect
RAK3244 to RAKDAP1 can be found on SWD Programming Interface section of RAK3244 datasheet

After ensuring the correct wiring connection, you can now flash the bootloader using pyocd command. If you do
not have pyocd installed on your system, check the pyocd installation guide


http://www.electroniccats.com/
https://github.com/ElectronicCats/Bast-WAN
https://github.com/RAKWireless/Evaluation_Boards/tree/master/RAK4260/Arduino
https://docs.rakwireless.com/Product-Categories/Accessories/RAKDAP1-Flash-and-Debug-Tool/Overview/
https://docs.rakwireless.com/Product-Categories/WisDuo/BastWAN/Datasheet/#interfaces
https://docs.rakwireless.com/Product-Categories/Accessories/RAKDAP1-Flash-and-Debug-Tool/Quickstart/#pyocd-installation
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pyocd flash -t atsaml21jl18a bootloader-bast-wan-v3.4.0.bin

Once the command is executed, the bootloader should be flashed successfully. You can now connect the
RAK3244 Bastwan to your PC.

Setting up the Things Network (TTN)

In this section, The Things Network (TTN) and the procedure to set up the platform to connect with RAK3244
BastWAN is explained.
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Figure 2: RAK3244 BastWAN in the context of the TTN

As shown in Figure 2, the RAK3244 BastWAN is one of the devices located on the left side. In the context of an
loT solution, the objective is to deploy devices to sense the relevant process variables and transmit the data to the
backend servers located in the cloud. The data will be processed and integrated as part of a larger solution that
could generate efficiency, traceability, predictability capacity among others.

The RAK3244 BastWAN can be part of this ecosystem, and the objective of this section is to demonstrate how
simple to send data to the TTN using the LoRaWAN protocol. To achieve this, the RAK3244 BastWAN must be
located inside the coverage of a LoRaWAN gateway.

NOTE:

The device name used for the setup is "RAK4260" since it is the core of RAK3244 BastWAN. You can
designate any device name you want on your setup.
Sign up and Login

If you don't have an account yet, head on to the TTN website 7 and create one. Once done, login to your account
and go to the Console.


https://www.thethingsnetwork.org/
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Figure 3: The Things Network Home Page
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Figure 5: Application Section
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2. Click the “add application” button.

‘?\ THETHINGS CONSOLE Applications ~ Gateways  Support O ttn_tests

O R K COMMUNITY ERITION

Warning The Things Network is shutting down v2 clusters later this year. Start moving your applications and devices to a v3 cluster! Click here to read more

Applications Add Application

ADD APPLICATION

Application ID
The unique identifier of your application on the network

Description
Ahuman readable description of your new app

Eg. My sensor network application

Application EUI
An application EUl will be issued for The Things Network block for convenience, you can add your own in the application settings page.

EUI issued by The Things Network

Handler registration
Select the handler you want to register this application to

ttn-handler-eu

Figure 6: Adding an Application

» Here are the things that you should take note in adding an application:

o Application ID - this will be the unique ID of your application in the Network. Note that the characters should
be in lower case, no spaces are allowed.

o Description - this is a short and concise human readable description of your application.

o Application EUI - this will be generated automatically by The Things Network for convenience.

o Handler Registration - handler you want to register this application to.

3. After you fill in the necessary information, press the "Add application" button at the bottom of the page. If you
see similar page as shown in Figure 8, then you have successfully registered your application.
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Warning The Things Network is shutting down v2 clusters later this year. Start moving your applications and devices to av3 cluster! Click here to read more
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Figure 7: Application Overview

Register a New Device

1. Scroll down until you see the Devices section. Or, you can click the "Devices" button at the top.
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Figure 8: Register a New Device

2. Then, register a new device by clicking on the "register devices".
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Device ID
This is the unique identifier for the device in this app. The device |D will be immutable.

Device EUI
The device EUl is the unique identifier for this device on the network. You can change the EUl later.

=
App Key
The App Key will be used to secure the communication between you device and the network.

Vd this field will be generated

App EUI
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Figure 9: Add your Device

In this form, the device ID must be unique for the application and must be completed with a lower case,
alphanumeric characters. The rest of the parameters in the form are very important for the LoRaWAN protocol:

» Device EUI
« Application Key
e Application EUI

The TTN platform can generate these parameters randomly by leaving those fields empty, or you can enter
already existing values.

3. Press the “Register” button at the bottom of this page to finish the process.
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Figure 10: Device Overview

Now that the Device EUI, Application EUI, and Application Key are defined, you can now proceed with the setup of
RAK3244 BastWAN LoRa configurations.

Using Arduino IDE to Modify and Flash Firmware

In this section, you will be introduced on how to use the RAK3244 BastWAN with Arduino™ IDE.

BSP Installation

1. After successful flashing of the bootloader, the BSP library should be installed. To add board support for the
RAK3244 BastWAN, start Arduino IDE and open the Preferences window by navigating through File >
Preferences. Now, copy and paste the following URL into the ‘Additional Boards Manager URLs' input field:

https://electroniccats.github.io/Arduino_Boards_Index/package_electroniccats_index.json . Then,

press the "OK" button.

Preferences X

Settings  Metwork

Sketchbook location:

C:\Usersluser\DocumentsArduing Browse
Editor language: System Default « | (requires restart of Arduino)

Editor font size: 12

Interface scale: Automatic = 100 5 % (requires restart of Arduing)

Theme: Default theme - | (requires restart of Arduina)

Show verbose output during: [ ] compilation [ upload

Compiler warnings: None  +

[] pisplay line numbers [] Enable Code Folding

Verify code after upload [] Use external editor

Check for updates on startup Save when verifying or uploading

[[] Use accessibility features

Additional Boards Manager URLs: |https://electroniccats. github.io/Arduino_Boards_Index package_electroniccats_index.json |[EI

More preferences can be edited directly in the file
C:\Users\user\appDatalLocal\Arduino 15Ypreferences. tet.
(edit only when Arduine is not running)

oK Cancel

Figure 11: Arduino additional board support

NOTE:

If there is already an existing URL on the textbox, click the button at the right end of the field. This will

open an editing window, allowing you to paste the above URL onto a new line as demonstrated in Figure
12.
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Figure 12: Alternative method for additional board support

4. Open the "Boards Manager" by navigating through Tools > Board > Boards Manager.

@ sketch_sep09a | Arduine 1.8.13 - [} b
File Edit Sketch Tools Help

Auto Format Ctrl+T
Archive Sketch
sketch_sep09 Fix Encoding & Reload
void setup() Manage Libraries... Ctrl+Shift+ ~
// PUE YRUE il Monitor Crl-+Shift+M
1 Serial Plotter Ctrl+Shift+L

void loop{) | WiFi101 / WiFiNINA Firmware Updater
/{ put your

Board: "Arduino Uno" : Boards Manager... |,\|\,'
} Port Arduino Yin
Get Board Info ®  Arduino Uno

Programmer: "AVRISP mkl" Arduino Duemilanove or Diecimila

Arduino Nano

Burn Bootloader

Arduino Mega or Mega 2560
Arduino Mega ADK
Arduine Leonardo

Arduino Leonarde ETH

Arduine Micro

Arduino Esplora
Arduine Mini
Arduino Ethernet
Arduine Fio
Arduino BT

LilyPad Arduino USE
LilyPad Arduino

Arduine Pro or Pro Mini
Arduino NG or older
Arduine Robot Control
Arduino Robot Motor
Arduino Germma

Adafruit Circuit Playground
Arduine Yin Mini

Arduino Industrial 101
Linino One

Arduino Uno WiFi

Figure 13: Arduino boards manager

1. Look for Electronic Cats SAMD Boards in the Boards Manager search bar. Click Install for the Electronic
Cats SAMD Boards, and wait for the installation to finish before closing the window.
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@ Boards Manager *

Type Al s | |Electronic Cats SAMD Boards|

Electronic Cats SAMD Boards
by Electronic Cats
Boards included in this package:

Meow Meow, CatWAN USB-Stick, CatWAN Relay board, BastWAN, CatWAN Citizen, Bast Pro Mini MO, Escornabot Makech, CatwaN
Tracker.

Cnline Help
More Info

2.0.5 ~ Install

Close

Figure 14: Installing Electronic Cats SAMD Boards

1. RAK3244 BastWAN should now be on the list of Boards by navigating through Tools > Board > Electronic
Cats SAMD(L)(C) Core for Arduino.

@ sketch_sep09a | Arduino 1.8.13 — [} b
File Edit Sketch Tools Help
Auto Format Ctrl+T
Archive Sketch
sketch_sep09 Fix Encoding & Reload
void setup() Manage Libraries... Ctrl+Shift+| ~
// put your Serial Monitor Ctrl+ Shift+ M
} Serial Plotter Ctrl+Shift+L

WiFi101 / WiFiNINA Firmware Updater

wvoid loop() {

/4 pur youx Board: "Arduino Uno" Boards Manager...
} Port Arduino AVR Boards >
Get Board Info Electronic Cats SAMD(L)(C) Core for Arduino Electronic Cats Bast Pro Mini MO
Programmer: "AVRISP mkll" 5 Electronic Cats CatWAN USB Stick

Electronic Cats Meow Meow

Burn Bootloader

Electronic Cats CatWAN Relay Board
Electronic Cats CatWAN Citizen
Electronic Cats Escornabot Makech
Electronic Cats CatWAN Tracker
Electronic Cats MCF Copy Cat

v Magspoof V3

BastWAN l}

Meow Meow Mini

Arduino Uno on COMS

Figure 15: RAK3244 BastWAN available in Boards list

LoRaWAN Library Installation

RAK3244 BastWAN board uses the Beelan-LoRaWAN library which supports LoRaWAN Class A and Class C
implementations operating in EU-868, AS-923, US-915 and AU-915 bands. You can recognize this library as the
<lorawan.h> on the sample code.

In order for the sample code to work, the Beelan-LoRaWAN library must be installed. To do this, navigate to Tools
> Manage Libraries on Arduino IDE. Then search for Beelan LoraWAN and install the latest version of the library.
The window indicates if the library is installed, as shown in Figure 15.



& RAK’ Documentation Center

@ Library Manager X
Type All ~ | Topic | All ~ || Beelan-LoRaWAN|
Beelan LoRaWAN ~
by Beelan Version 1.5.4 INSTALLED
LoRaWAN Arduino Library for standal LoRaWAN dules class A and C with a simple APL. Device library for LoRaWAN network US, EU

and AS. Support SX1276/72 or RFM95
More info

Select version Install

Close

Figure 16: Beelan LoRaWAN library installed

Visit the Beelan-LoRaWAN official github repository % for more information.

First Test

For a quick test, a sample source code is provided for a LoRaWAN Class A node with OTAA support. Download
the source code and open it with Arduino IDE.

« Example source code for RAK3244 BastWAN [

The following sections will demonstrate how to modify LoRaWAN parameters to establish a connection with The
Things Network (TTN).

Modifying LoRaWAN Parameters

For the RAK3244 BastWAN to successfully connect to a LoRaWAN Platform, several parameters must be properly
configured. Not doing so will result in connection failure.

The most volatile parameters on LoRaWAN configuration are the Device EUI, Application EUI, and Application
Keys. These data must match with the ones on The Thing Network (TTN) platform. Copy the EUIs and Keys from
the TTN platform and paste them on the sample source code. Figure 17 shows the lines of codes that should be
modified:

@ bastwan_test | Arduino 1.8.13
File Edit Sketch Tools Help

hastwan_test

finclude <lorawan.h>

// OTAR credentials
lconst char *devEuil "00ED3EL1B17FCE350";
"JOB3DSTEDOO3ADTO";

"BOFGBCS9A31BB2B4CAD400E0EFTGRBCCCY

const char *appEui

const char *appRey

Figure 17: Device EUI, Application EUI, and Application Keys

Compiling and Flashing the Firmware


https://github.com/BeelanMX/Beelan-LoRaWAN
https://github.com/RAKWireless/Evaluation_Boards/tree/master/RAK4260/Arduino/send-class-A-OTAA
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Now that the LoRaWAN parameters are set, you can now run the sample program.

Click the Verify button on the upper left of Arduino IDE to compile the code. Before uploading the sample
firmware, make sure that the RAK3244 BastWAN is connected and recognized by your PC. To verify this, there

must be an assigned port on the Tools toolbar of Arduino IDE. It should not be grayed out.

@ bastwan_test | Arduino 18.13 - X
File Edit Sketch Tools Help

> interval) {

d", counter);

lora.sendUplink (myStr, strlen{myStr), 0, 1);
counter++;

¥

recvstatus = lora.readData(outStr);

if(recvstatus) {

Serial.println(outStr);

¥

// Check Lora RX
lora.update () ;
} v

Figure 18: Compilation of sample source code

If everything is well, you can now click the Upload button and the firmware should be flashed to your RAK3244
BastWAN.

@ bastwan_test | Arduino 1.8.13 - X
File Edit Sketch Tools Help

Figure 19: Uploading of sample source code

The RAK3244 BastWAN will try to join the LoRaWAN network server, and if it is successful, it will send a string to
verify its presence. You can find more details of the operation by examining the sample source code and opening
the serial monitor.

Feel free to experiment with your own and explore the capabilities of RAK3244 BastWAN.
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